Jump to content

Video is not the main content of the page (SEO)


Maciej

Recommended Posts

  • 3 weeks later...
8 hours ago, Jim said:

Does KVS conform to all of this for videos?

Yes, except for this:

Quote

Use stable URLs for video and thumbnail files

However this was never the problem before. KVS is whitelisting Google bot IPs and MSN bot IPs when serving video files. If you want to show the same video URL for all videos, you can switch off hotlink protection in Settings -> Content settings -> Hotlink protection type option (set to By referrer).

Link to comment
Share on other sites

19 hours ago, Egg said:

That's interesting. We changed URLs from /videos/ to /video/ on demo site and also added a "Video" word at the end of title:

https://www.kvs-demo.com/video/219/kylie-minogue-all-the-lovers/

 

14 hours ago, Jim said:

Are the video sitemap best practices and example also followed?

https://developers.google.com/search/docs/crawling-indexing/sitemaps/video-sitemaps

Yes, should be all supported for a very long time.

Link to comment
Share on other sites

6 hours ago, Jim said:

This is also used by default in KVS theme. If any of the recommendations were not used, Google would not index videos at all. The new issue comes when Google introduced new AI that is deciding on whether the video is main content on the page or not. Now everyone is trying to guess what will force this AI to consider video as a main content.

Link to comment
Share on other sites

Some positive news. We got effect after renaming video URL pattern to contain "video" instead of "videos" and adding "Video" word after every video title in H1 tag. Looks like this tricks Google AI to believe that this is a main video content:

google_video_indexing.thumb.png.2276bd1801c6e78208215bc8a17a45d5.png

 

What are the steps:

1) In ./htaccess file in your www root directory (can be edited via FTP or server File Manager) locate these 2 lines going together:

RewriteRule ^videos/([0-9]+)/([^/]+)/$      view_video.php?id=$1&dir=$2 [L,QSA]
RewriteRule ^videos/([^/]+)/$               view_video.php?dir=$1 [L,QSA]

and change ^videos/ to ^video/ in URL pattern (beginning of the line):

RewriteRule ^video/([0-9]+)/([^/]+)/$      view_video.php?id=$1&dir=$2 [L,QSA]
RewriteRule ^video/([^/]+)/$               view_video.php?dir=$1 [L,QSA]

If you don't have these lines, likely your theme is customized to use some other video page URLs, this guide provides only information about default KVS theme URL pattern.

Also in the upper section of this same file named "# seo redirect rules" add these lines to redirect old video URLs to new:

RewriteRule ^videos/([0-9]+)/([^/]+)/$  /video/$1/$2/ [R=301,L,QSA]
RewriteRule ^videos/([^/]+)/$  /video/$1/ [R=301,L,QSA]

 

2) In KVS admin panel go to Settings -> Website settings and modify Video page URL pattern to "video" instead of "videos". Now all your video pages should be using the new URL pattern.

 

3) (NOTE: some comments below suggest this is not required) In KVS admin panel go to Website UI -> Pages -> Video View block under View Video page and in template code modify this line:

<h1>{{$data.title}}</h1>

to this:

<h1>{{$data.title}} Video</h1>

Not sure if the last step is actually required, but we did these 2 steps at the same time, so not clear which one (or them both) made effect.

This was done based on this info and it looks to align with their findings:

On 1/13/2024 at 5:29 PM, Egg said:

 

  • Thanks 2
Link to comment
Share on other sites

21 hours ago, Egg said:

Results by only applying step 1. Naturally there are quite a few videos with 'video' in the middle or end of the title and/or description. 

Screenshot 2024-01-24 031316.png


did you do the step 2 ?

2) In KVS admin panel go to Settings -> Website settings and modify Video page URL pattern to "video" instead of "videos". Now all your video pages should be using the new URL pattern.

or just you did the step 1?

i now did just step 1 and step 2 and i will report back

Link to comment
Share on other sites

22 minutes ago, naughtyking said:

or just you did the step 1?

Step 2 should be done as well, otherwise URLs will not be changed. I guess he was trying to say he didn't add "Video" to the H1, which is step #3 in this guide:

Quote

3) In KVS admin panel go to Website UI -> Pages -> Video View block under View Video page and in template code modify this line:

 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...