Jump to content

Upload problem.


root012
 Share

Recommended Posts

I have problem with uploading, I change upload size in my php.ini file and upload size now is 2GB i test and all is okay, but when I want to upload some video via KVS he write me "the file size is greater than allowed by server config" I also change upload size in nginx conf file.

Link to comment
Share on other sites

There are several places where upload limit can be configured.

 

In php.ini there are 2 directives:

- upload_max_filesize

- post_max_size

 

You can change them in php.ini globally, or you can provide local values in the main .htaccess file (if your webserver allows overrride PHP configuration value from .htaccess files):

 

php_value upload_max_filesize 2000M
php_value post_max_size 2000M

 

Another place where there is a limit is nginx config. Typically this is configured in the main nginx.conf file using the following directive:

 

client_max_body_size

 

But it can be overridden in many contexts, here is documentation for this option:

https://nginx.org/en/docs/http/ngx_http_core_module.html#client_max_body_size

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...